Ubuntu libcairo issue

Due to the increasing traffic on my site, related to this Ubuntu issue, I'll static link it, so it's more reachable and visible (or this is what I hope)

Please, if you find this post useful just leave a comment here.
Thank you :qt:

Here's what happened

I couldn't open some gnome applets/apps or they had strange behaviours (update-manager didn't show up the window, synaptic failed to show the packages repository list)

Traceback (most recent call last):
  File "/usr/bin/gnome-software-properties", line 28, in ?
    import gtk
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 37, in ?    from <em>gtk import *
ImportError: /usr/lib/libcairo.so.2: undefined symbol: FT</em>GlyphSlot_Embolden

Here's the catch: https://launchpad.net/distros/ubuntu/+source/libcairo/+bug/6100

How to fix? Enable/add the dapper repo into your /etc/apt/sources.list
Open up a terminal and type in

$ sudo gedit /etc/apt/sources.list

then add in the end this

deb http://archive.ubuntu.com/ubuntu dapper main restricted

This is the repository of the incoming (April) version of Ubuntu, the Dapper Drake.
Save (you can let the window open).

Now open synaptic (or use apt-get), refresh the list and then update ONLY libfreetype6 :)

Now you can comment out the repository you added :)
If you closed gedit

$ sudo gedit /etc/apt/sources.list

and then comment the line you added as follows

#deb http://archive.ubuntu.com/ubuntu dapper main restricted

bye ;)

related pages:
https://launchpad.net/distros/ubuntu/+source/libcairo/+bug/6100
https://launchpad.net/distros/ubuntu/+source/freetype/+bug/5901
http://ubuntuforums.org/showthread.php?p=606923#post606923

Categories

Archives

Blogroll

Last 10 entries

Admin area